If your touchscreen grill isn’t pairing via Bluetooth or connecting to WiFi, the issue may be a disconnected or damaged WiFi antenna. This guide walks you through how to inspect, reconnect, or replace the antenna.
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Symptoms
- App is stuck on "Searching For Grill".
- Grill fails to pair with the Traeger app via Bluetooth.
Causes
- Antenna cable disconnected inside the Smart Combustion Motherboard.
- Loose or improperly seated antenna connector.
- Damaged antenna cable (pinched or worn).
What to Do
- Turn off and unplug the grill.
- Remove the hopper service panel (right panel).
Pro Tip: Remove the P.A.L rail to access the service panel screws more easily.
Before removing the hopper service panel: check your grill’s manufacturer date.
- June 2023 (2306) or after: Proceed to remove service panel.
- Before June 2023 (2305): Remove the access panel using an impact driver to prevent the possibility of stripped screws. If you don't have one on-hand, contact Traeger Support.
- Remove the hopper side service panel by removing 6 screws (2 located on top of the access panel, 2 below the hopper side rail, and 2 on the bottom of the access panel).
- Remove the smart combustion cover.
- Locate the antenna.
- The WiFi antenna is connected to the motherboard.
- Look for a small coaxial cable connected to a gold or silver antenna port on the motherboard.
- Inspect the Connection.
- Ensure the cable is securely snapped into place.
- If the cable is loose or disconnected, gently press it back into the port until it clicks.
- Check for Damage
- Look for any fraying, pinching, or visible damage to the antenna cable.
- If the cable is damaged, reach out to Customer Support.
- If the cable is not damaged, move to step 8.
- Look for any fraying, pinching, or visible damage to the antenna cable.
- Reassemble and Test.