WiFIRE Grill Shuts off Mid-Cook

What's in This Article?

So your D2, WiFi-enabled Traeger grill shut off in the middle of your cook. What should you do now?

 

Symptoms

  • Your grill shuts off without you initiating the shutdown cycle, unplugging the grill, or losing power.
    • Some users may refer to this as, "sleep mode," but the grill actually powers off. 
  • Most common on grills paired with an Android device running an old version of the Traeger app

Causes

A grill shutting off in the middle of a cook is most often caused by one of the following:

  • Power outage or tripped outlet/breaker
  • Traeger app is on a previous version
  • Grill firmware on a previous version
  • Grill wiring disconnected or damaged

What to Do

  1. Check if the power went out, if the outlet or your breaker tripped, or if the grill became unplugged.
    • Grill should be connected to an outlet on a 15A or 20A breaker. Breakers with different amperage can allow for grill to shut off mid-cook.
  2. Make sure your Traeger app is on the latest version.
  3. Check your grill's firmware to make sure it's on the latest version. 
  4. If the grill shut off mid-cook while on the latest app version, please contact Traeger's Customer Support so we can continue gathering additional instances of this issue.
    • To continue grilling without the grill shutting off in the middle of your cook, opt to control your grill using the grill's controller instead of the Traeger app. 
Previous
Next
15272110913179

Was this article helpful?

56 out of 645 found this helpful