Power Issues on Non-Connected Pellet Grills

What's in This Article?

If your grill isn't turning on or unexpectedly turns off, follow the troubleshooting steps in numbered order to determine the source(s) of the problem. Do not deviate.

Related Articles & Links
About AC Controllers AC Grill Controllers
Blown Fuses Blown Fuses
Specific Display Issues Non-WiFIRE (AC) Controller Display Issues
Wiring
 
AC Grill Wiring
Non-WiFIRE Grill Grounding Wires
Working on an AC WiFIRE Grill? Grill Power Issues - AC Timberline

A Non-WiFIRE grill can experience power concerns at any point before or throughout the cooking process.

Symptoms

This article covers power issues as a general topic, primarily applied to the controller not turning on. 

 Non-WiFIRE (AC) Controller Display Issues offers additional insight into specific issues including the following:

  • Cracked or damaged screen
  • Flickering screen
  • Screen flashing on briefly and then turning off
  • Missing, dimmed or partial numbers showing
  • 3 dashes (---) or 888

Causes

Power issues may be caused by many factors, which we explore in the troubleshooting below. Most often, causes include the following: 

  • Tripped outlet
  • Faulty extension cord
  • Dial set to Shutdown (common if controller flashes on and off)
  • Wiring connections
  • Blown fuse on the controller
  • A specific part tripping an outlet
  • Occasionally, a failing controller

Troubleshooting Steps

Follow the steps below in order.

1. Check if the controller is set to "Shutdown"

When the dial is left on Shutdown, the grill won't power up, even if it's plugged in and the outlet is working. Verifying this early can save time and help avoid unnecessary troubleshooting.

  1. Make sure the controller dial is not set to the shutdown cycle. 
  2. Turn the grill ON.

2. Check Power Connections

  1. Confirm the grill is plugged in and the power switch is set to the ON position.
  2. Is the Grill Connected via an Extension Cord?
    • Occasionally extension cords fail. Try plugging the grill directly into the outlet. If the outlet is too far for the cord to reach, try plugging another device into the extension cord to confirm it's delivering power.
  3. Inspect the Power Cord
    1. Look for any signs of damage or kinks.
      • If there is any damage to the power cord, take photos to document the damage and replace the power cord.
    2. Confirm the Internal Parts of the Power Cord Aren't Damaged.
      1. Access the internal portion of the power cord through the bottom of the hopper. 
        • Depending on your grill model, you may need to remove the protective grate by removing the screws securing it in place.
      2. Thoroughly inspect the internal parts of the power cord for damage, such as frayed wires from rodents, etc. 
        • If there is any damage to the power cord, take photos to document the damage and replace the power cord.
           

3. Inspect if the GFI Or GFCI Outlet Tripped

  1. If plugged into a GFI or GFCI outlet (outlet with a small center button, commonly found in bathrooms or near water), did the outlet trip?
  2. If so, reset the outlet by pressing the center button.
  3. Turn the grill ON.
  4. Ignite the grill and let run for 5 minutes.
  5. If the outlet trips again, continue troubleshooting.
    • If the center button does not pop out, the outlet did not trip, and the outlet is not the issue. This means one of the components is the issue.
    • For further resolution, continue to step 5 below: [Determine Which Part is Tripping the Outlet].
  6. See if the outlet is the problem:
    1. Unplug the grill, plug another appliance (toaster, blow dryer, coffee maker) into the outlet, and turn it on.
      • The appliance must pull at least 300 watts for this test to work. Small appliances similar to those listed should work. A phone charger will not suffice.
    2. If the GFI outlet trips again, there is an issue with the outlet or the circuit box. Please consult an electrician to resolve the issue.
      NOTE: GFI (GFCI) outlet information – Although GFI outlets have a lifespan of 20 years, they often begin to have issues after 5 years.
  7. If the outlet does not trip with another appliance, the grill is tripping the outlet. Proceed to the next step.
  1.  

4. Check the Controller's Fuse

  1. Turn off and unplug the grill.
  2. Unscrew the controller from the grill.
  3. Find the fuse and remove it to inspect it.
    • Fuses are found on the back of the controller in one of two locations: a green or grey box with a lid or a black tube with a screw-on cap.
      ARC_controller_BACK_SIDE.jpeg blown_fuse_1.png blown_fuse_2.png
  4. A blown fuse will have burn marks or broken filaments, similar to a burnt-out lightbulb.
AC-fuse_blow.gif
  1. If blown, proceed to replace the fuse and determine the cause.

4.1. Replace the Fuse (only if blown)

Most grills come with an extra fuse, zip-tied to the back of the fuse box.

If you have already used your spare fuse or if the spare is missing, you can purchase an extra fuse at a hardware store (3-5 Amp 250 Volt, standard size fuse). 

  1. Turn OFF and unplug your grill.
  2. Remove the screws holding the controller in place.
  3. Pull out the controller from the hopper.
  4. Look for the fuse, which may be inside a small green or grey box or tube or zip tied to the top of the fuse box. See the images above. 
  5. Remove the tube or box cover.
    • If there is a zip tie holding the extra fuse to the fuse box, cut the zip tie to access the fuse.
    • The box lid should pull off, and tube lids need to be unscrewed.
  6. Pull out the fuse from the box or tube.
    • Older elite controllers will still have a bus fuse, but it will be set on the board vertically inside a black pod.
      1. Unscrew the cap off of the pod with the small metal knob. Push down lightly, then turn counterclockwise and let go. It will release.
      2. Pull the fuse up and out of the little black cylinder (pod). The knob must be pulled off the old fuse and returned to the new bus fuse.
      3. To replace, put the fuse back in the pod, push down, turn clockwise, and let go.
  7. NOTE: Before proceeding with the last step, unplug ALL components from the grill in case one of the components is blowing the fuse. Refer to [AC Grill Wiring] to identify which connector goes to which component. 
  8. Replace it with the extra fuse that came with your controller, or you can purchase fuses from any hardware store (3-5 Amp 250 Volt, standard size fuse).
  9. Proceed to determine what caused the fuse to blow, or it will likely pop again.

5. Determine Which Part of the Grill is Tripping the Outlet or Blowing the Fuse

TOOLS NEEDED: Phillips Screwdriver, Extra Fuse (should come attached to the controller)

Determining the cause of a tripped outlet or blown fuse differs based on which controller your grill has: an ARC controller or a Pro/Digital Controller.

Determining the Cause of a Blown Fuse: ARC Controller

  1. With the controller removed, inspect the wires to make sure they aren't damaged and that there isn't any rubbed/melted insulation on them.

  2. Disconnect the red, orange, and purple wires from their Molex connectors. Leave the black attached. (See [Controller Wiring Diagram] below)

  3. Install the spare fuse.

  4. Plug in and turn on the grill. See if the display blinks/flashes on and off.

    • Display Blinks Fuse Replaced Next Step
      No No Replace Fuse
      No Yes Replace power cord & controller
      Yes Yes Proceed to next step
  5. Ignite the grill and let run for 5 minutes.

    • If the fuse trips, the issue is either with the power cord, the controller, or the fuse. Replace all three parts.

    • If the fuse does not trip, continue to the next step. The issue is NOT with the cord, controller or fuse.

  6. CHECK THE HOT ROD (this is the most common culprit of a blown fuse).

    1. Connect the hot rod (tan wires) to the controller (purple/white wires).

    2. Plug the grill into power and turn ON the grill.

    3. Ignite the grill and let run for 5 minutes.

      • If the fuse trips, replace the hot rod and the fuse.
        If the fuse does not trip, turn off the grill and continue.

  7. CHECK THE FAN

    1. Connect the induction fan (orange wires) to the controller (orange/white wires).

    2. Plug the grill into power and turn it ON.

    3. Ignite the grill and let run for 5 minutes.
      You should be able to see the fan from under the grill and hear the fan running.

      • If the fuse trips, replace the fan and the fuse. 
        If the fuse does not trip, turn off the grill and continue.

  8. CHECK THE AUGER MOTOR

    1. Connect the auger motor (red wires) to the controller (red/white wires).

    2. Plug the grill into power and turn it ON.

    3. Ignite the grill and let run for 5 minutes.

      • If the fuse pops, replace the auger motor and the fuse.

  9. If the fuse does not blow with all checks, replacing the fuse solved the problem.

    • PRO-TIP: Zip-tie wires together once you're done working on your grill. This will ensure they don't block the fan and get damaged.  

Determining the Cause of a Blown Fuse: Pro/Digital Controller

  1. With the controller removed, inspect the wires to make sure they aren't damaged and that there isn't any rubbed/melted insulation on them.

  2. Disconnect the red, orange, and purple wires from their Molex connectors. Leave the black attached. (See [Controller Wiring Diagram] below)

  3. Confirm power by plugging in the grill and powering it on. If the dial is on Shutdown Cycle, move it to another position. The red LED light on the back of the controller should light up.
    AC_controller_power_light_example.png

    • If the LED light does not turn on, and the power cord looks good: replace the controller.

    • Replace the power cord if the small red light is flickering/blinking; and only if there is a problem with the power supply.

  4. Ignite the grill and let it run for 5 minutes.

    • If the fuse trips, the issue is either with the power cord, the controller, or the fuse. Replace all three parts.

    • If the fuse does not trip, continue to the next step. The issue is NOT with the cord, controller or fuse.

  5. CHECK THE HOT ROD (this is the most common culprit of a blown fuse).

    1. Connect the hot rod (tan wires) to the controller (purple/white wires).

    2. Plug the grill into power and turn ON the grill.

    3. Ignite the grill and let it run for 5 minutes.

      • If the fuse trips, replace the hot rod and the fuse.
        If the fuse does not trip, continue.

  6. CHECK THE FAN

    1. Connect the induction fan (orange wires) to the controller (orange/white wires).

    2. Plug the grill into power and turn it ON.

    3. Ignite the grill and let it run for 5 minutes. You should be able to see the fan from under the grill and hear the fan running.

      • If the fuse trips, replace the fan and the fuse. 
        If the fuse does not trip, continue.

  7. CHECK THE AUGER MOTOR

    1. Connect the auger motor (red wires) to the controller (red/white wires).

    2. Plug the grill into power and turn it ON.

    3. Ignite the grill and let it run for 5 minutes.

      • If the fuse pops, replace the auger motor and the fuse.

  8. If the fuse does not blow with all checks, replacing the fuse solved the problem.

    • PRO-TIP: Zip-tie wires together once you're done working on your grill. This will ensure they don't block the fan and get damaged. 

6. Inspect the Controller

  1. Turn OFF and unplug the grill.
  2. Unscrew the controller and carefully pull it away from the grill to see the connections in the back.
  3. Disconnect and reconnect all connections.
  4. Plug in and turn ON the grill.
  5. Pro/Digital Controllers Only: Check if the red LED light in the top corner of the controller is lit up.
    ARC controllers do not have this light.
    power_issues_1.png
    1. If the small red light on the back of the controller is NOT on, but the power cord looks good: Replace the controller.
    2. If the small red light is flickering or blinking:
      1. There is an issue with the power supply: Replace the power cord.
      2. If the small red light on the back of the controller IS on and the fuse is NOT blown (see Check the fuse on the step directly below), but the controller's LED screen is not working, replace the controller.
      3. ARC controllers do not have a fuse light. If all components are unplugged from the controller, but the power cord and the grill/controller continue to not power on, jump to step [5. Confirm the Internal Parts of the Power Cord Aren't Damaged].

AC Grill Wiring Diagram

NOTE: While the image in the diagrams below depict a Pro controller, the wiring applies to any type of AC controller. The wiring is the same regardless of the controller face.

AC_Wiring_-_All_Connected.pngAC_Wiring_-_All_Disconnected.png

Previous
Next
4407219868187

Was this article helpful?

217 out of 1191 found this helpful