What to do if your Westwood series grill is not getting power.
Important: Ensure the protective film has been removed from the controller display prior to use. Failure to remove the film can affect the controller's responsiveness to button presses as well as cause "phantom" button presses.
Symptoms
If your grill is not turning on, it usually means one of the following:
- Controller display is not turning on: Refer to Westwood Series Controller Blank/Not Turning On.
- Grill is not igniting: Refer to Westwood Series Grill Not Igniting.
- Grill is not getting power (indicator below the flame icon is not lighting up): Continue with this article.
Important! If the indicator beneath the flame icon is lighting up, the grill is getting power. The controller may be asleep. Press the + or - button to wake the controller.
Causes
- Wire connections to the controller are not securely connected.
- Wire connections to the power switch are not securely connected.
- Faulty outlet or extension cord.
- Faulty parts
What to do
1. Check the Power Source
- If the outlet is a GFI/GFCI outlet, make sure it hasn't tripped by pressing the RESET button.
- Plug another appliance (toaster, blow dryer, coffee maker) into the outlet and turn it on. The appliance must pull at least 300 watts for this test to work. Small appliances similar to those listed should work. A phone charger will not suffice.
- If there is no power, try another outlet, have the customer see if their circuit breaker tripped, or have the customer consult an electrician for that outlet.
- If the outlet is working, check the power source/components
- Ensure the cord is undamaged and fully plugged in. If the power cord is damaged, replace the power cord.
- If using an extension cord, plug the grill directly into the outlet. If grill powers on, the extension cord is at fault.
2. Check Component Connections
1. Access the Controller
- Turn OFF and unplug the grill.
- Remove the hopper service panel (side of hopper).
2. Remove the Controller
- Remove the 4 thumb nuts (one in each corner of the controller)
- Hand-remove if possible
- Use a 1/2" socket wrench if tight
- Disconnect the green ground wire from the lower inside weld stud
- Disconnect the RTD
- Carefully pull the controller inward into the hopper
3. Reset Wire Connections
- Unplug and firmly reconnect all 4 controller wire connections
4. Reassemble (Partial)
- Reinstall the controller
- Reconnect the ground wire
- Reconnect the RTD
5. Test for Power
- Leave the hopper service panel off
- Plug the grill back in and turn it on
If the grill powers on: Issue is resolved
If no power: Continue below
3. Check Controller LED Lights
- Look for 3 red LED lights on the back of the controller
- If lights are ON, the grill has power: Press the + or – button to wake the controller
- If lights are OFF: Continue troubleshooting
4. Check Power Switch Connections
Reset Connections
- Turn OFF and unplug the grill
- Disconnect both red wires from the back of the power switch
- Reconnect them securely
Test Again
- Plug the grill back in
- Turn the power switch ON
- If grill still does not power on, contact Traeger Support