What to do if the lid light on your Touchscreen grill does not turn on.
Symptoms
When opening the grill lid, the light does not turn on.
Possible Causes
- Lid magnet missing
- Outdated firmware
- Bad wiring connection
- Faulty lid sensor & light
Resolution
- Verify magnet is on the grill lid.
- If missing, send a replacement.
- Find the grill's firmware version and make sure it's up to date.
- Ensure the grill is cool and finished with its shutdown cycle (if applicable).
- Run a SELF-TEST to ensure there are no disconnects. Follow the steps below:
- On the controller display, go to MENU > MAINTENANCE & CARE > SELF-TEST.
- If the Lid/Light passes the SELF-TEST, everything is good, and no replacement is needed.
- If it fails, continue troubleshooting.
- On the controller display, go to MENU > MAINTENANCE & CARE > SELF-TEST.
- Turn on the grill.
- Close and open the lid to see if the light turns on.
- There may be a few seconds delay for the light to turn on.
- If the light still does not turn on, replace the light/light sensor.