What to do if a customer's D2 WiFIRE grill produces a "Fan Disconnected" error.
Related Articles & Links
- Buy a draft induction fan for a D2 WiFIRE grill on traeger.com
- What Is an induction fan?
-
Induction Fan Replacement Instructions for D2 WiFIRE Grills
Symptoms
The grill's controller displays a message saying, Fan Disconnected. If paired with the Traeger app, the app may also issue a push notification with the same verbiage.
Common Causes
- Fan wiring has disconnected from the back of the controller
- Damage to the fan wiring harness
- Induction fan needs to be replaced
What to Do
- Turn off and unplug the grill.
- Unscrew the controller and pull it out enough to see the wires connected to the back.
- Check if the fan is correctly connected to the controller (connector with the black, red, white, and tan wires).
- See D2 WiFIRE Grill Wiring for additional details on wiring connections on D2 WiFIRE grills.
- Disconnect and reconnect to ensure a solid connection, even if the harness appears to be connected.
- Plug in and power on the grill and check if the error has cleared.
- Remove the bottom or side panel of the hopper so you can view the grill's internal components and locate the induction fan.
- Ignite the grill so you can check if the fan starts spinning.
- If the fan is disconnected, the fan will not spin.
- Proceed based on your findings:
- Error cleared; fan spinning: Success! Reconnecting the wires to the controller fixed the issue.
- Error continues; fan spinning: Replace the controller.
- Fan doesn't spin: Replace the induction fan.