Lid Sensor Error - Timberlines & Ironwoods

What's in This Article?

What to do when your new Timberline or Ironwood displays, 'Lid Sensor Error' (Error: 0023).

gen2-0023_lid_sensor_error.jpeg

 

Symptoms

The controller will display the error shown above, and if paired, you will receive a push notification to your phone.

The grill will continue to operate when this error occurs, meaning you will be able to continue grilling and have successful future cooks even with this error showing up.

The error should clear on its own or clear with a power cycle.

Possible Causes

This error occurs when, during a cook, the lid sensor reports that the lid is open, but the controller does not see a drop in temperature. This is usually caused by one of the following:

Old firmware
Loose wiring connection
Lid magnet missing
Faulty part

Resolution

  1. Find your grill's firmware version and make sure it's on the current version. 
    Most error are caused by the grill running on old firmware; not part failure.
  2. Confirm the lid sensor & light is working.
    1. Make sure the grill's lid magnet is in place.
      If your lid magnet is missing, contact our Customer Support team, and we'll send you a new magnet. 
      gen2_0023_magnet_placement.jpeg
    2. With the grill turned on, make sure the lid light turns on when opening the lid and that it turns off when closing the lid. 
      • If the light functions correctly, the sensor is working. The issue is likely with firmware. Re-check your firmware version and power cycle your grill to clear the error.
      • If the lid light does not turn on/off when opening/closing the lid, respectively, The sensor may have come disconnected or you may need to replace the lid sensor. Remove the hopper service panel to check wiring connections.

IMPORTANT: Before proceeding

To continue you'll need to remove your hopper service panel. To remove this panel for the first time, you'll need to use an impact driver to remove the screws behind the P.A.L rail on your hopper service panel. 

  1. If this is your first time removing the hopper service panel and you don't have an impact driver of your own. Contact our customer support team and we'll send you a complimentary manual impact driver.
    • If you already have a manual impact driver, proceed to removing the hopper service panel.
    • If you have already removed the service panel screws, you can disregard the impact driver and use a regular Phillips screwdriver.
  2. Once you've removed the screws using the impact driver, continue with the next steps outlined here in this article.

Once you've verified current firmware and have the hopper service panel removed:

  1. Turn off and unplug your grill.
  2. Remove the smart combustion cover.
  3. Disconnect and reconnect the lid sensor wiring connections all connections.
    1. Disconnect and reconnect the Smart Combustion connection at the motherboard.
      Gen2_Motherboard-smartcomb_grease.jpeg 
    2. Find the lid sensor and disconnect and reconnect the two wiring connections.
      yos_lidsensor_wiring.JPG
  4. Inspect the wires to make sure they aren't pinched, cut, or damaged.
    • If wiring is damaged, contact Customer Support so we can get you set up with new wire harnesses and help you diagnose the issue further. 
  5. Turn on your grill. The error should clear and the light should function when opening and closing the lid.
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