What to do if your WiFIRE-enabled grill's controller displays a negative temperature or shows the temperature going down as the grill is heating up.
This Article Applies to the Following Grills:
- D2 Grills
- Touchscreen Grills
Symptoms
- The grill's temp shows negative or is dropping during startup.
- As the grill preheats, the temperature on the controller display goes down instead of up, even though the grill's actual temperature is going up.
Common Causes
Typically, the reason for your temperature reading backward is because the thermocouple wires are installed backward.
What to Do
D2 Grills
- Power off and unplug your grill.
- Unscrew the controller from the hopper to access the thermocouple's connection point.
- Find the yellow thermocouple connector.
- Verify that the + and - signs match the + and - on the controller.
- If installed in reverse, disconnect the thermocouple by pulling it away from the controller and connect correctly.
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Turn on the grill and ignite to verify the temperature goes up correctly.
- If the temperature still goes down, contact Customer Service..
Touchscreen Grills
- Power off and unplug your grill.
- Use a manual impact driver to remove the hopper service panel and the Smart Combustion Cover.
Important: Before removing the hopper service panel, check your grill’s manufacturer date.
June 2023 (2306) or after:
- Proceed to remove service panel.
Before June 2023 (2305):
- Removing the service panel on grills manufactured before June 2023 should be done using a manual impact driver to prevent the possibility of stripped screws. If you do not have an impact driver on hand, please contact Traeger Customer Support.
- Find the yellow thermocouple connector.
- Verify that the + and - signs match the + and - on the motherboard.
- If installed in reverse, disconnect the thermocouple by pulling it away from the motherboard and connect correctly.
- Turn on the grill and ignite to verify the temperature goes up correctly.
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If the temperature still goes down, contact Customer Service.
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