This article will cover the causes and resolutions for the following errors: Er3, Er5, Er6, and Er7. These errors are for AC grills only.
Er3 & Er5
Cause
This is when the grill has failed to ignite or the ignitor is disconnected.
Resolution
- Unscrew the 4 screws on each corner of the controller.
- Carefully pull the controller away from the grill.
- Make sure the connections are secure and not loose.
- Disconnect and reconnect the wires.
- If connections are fine but the error messages are still showing, contact Customer Support to replace the hot rod.
Er6
Cause
The auger has been disconnected.
Resolution
Replace the auger motor.
- On the bottom grate under the hopper, locate the 4 screws that hold it in place and remove them.
- Remove the 2 screws holding in the controller.
- Once removed, rotate the controller, so you can push it through where it was housed.
- Unless already removed, clip the zip ties holding all the wires together.
- Locate the 4 screws holding the hopper assembly on the grill and remove them (2 on either side).
- Carefully remove the hopper assembly.
- Remove the 1/4-inch bushing screw (the screw holding the auger to the frame of the grill).
- Using an Allen key or 5-16-inch socket wrench, remove the Shear pin, freeing the Auger from the Auger motor.
- Once the shear pin is removed and the auger is free, disconnect the old auger motor and connect the replacement.
- If the error Er6 still appears, contact Customer Service.
Er7
Cause
This is when the auger has jammed.
Resolution
- With the grill in 'Idle' mode, press and hold the 'DOWN' and 'IGNITE' buttons at the same time.
- The display will flash "Clr" and the auger will cycle between moving forwards and backwards for 60 seconds to clear the auger jam.
- To stop this sequence before it is complete, press and hold the 'DOWN' and 'IGNITE' buttons at the same time.
- If further assistance is needed, contact Customer Support.