What to do if your WiFIRE-enabled grill's controller displays a negative temperature or shows the temperature going down as the grill is heating up.
Symptoms
- The grill's temp shows negative or is dropping during during startup.
- As the grill preheats, the temperature on the controller display goes down instead of up, even though the grill's actual temperature is going up.
Common Causes
Typically, the reason for your temperature reading backward is because the thermocouple wires are installed backward.
What to Do
- Power off and unplug your grill.
- Access the thermocouple's connection point.
- D2 WiFIRE Grills: Unscrew the controller
- New Timberlines & Ironwoods: Use a manual impact driver to remove the hopper service panel and the Smart Combustion Cover.
- Find the yellow thermocouple connector.
- Verify that the + and - signs match the + and - on the motherboard or controller.
- If installed in reverse, disconnect the thermocouple by pulling it away from the controller and and connect correctly.
- Turn on the grill and ignite to verify the temperature goes up correctly.
-
- If the temperature still goes down, continue.
-
- Swap the thermocouple wires.
- Unscrew the two Phillips-head screws that secure the wires to the connector.
- Switch the wire placement so the wire that was connected to the + is now connected to the -, and vice versa.
- Turn on the grill and ignite and confirm the temperature goes up.
- If the previous steps do not fix the problem, contact Customer Service.