Are your TXM probes frequently connecting and disconnecting?
Symptom
Traeger X MEATER (TXM) probes continually pairing and disconnecting.
Cause
There are a few reasons the TXM probes connect and disconnect.
- Old Firmware
- Bluetooth interference with other Bluetooth devices connected to grill (i.e. Induction Cooktop)
- Swapped probe
- Quick battery depletion
- Broken probe
Resolution
- Check the grill is on that latest Firmware.
- If the Firmware is out of date, please upgrade firmware. See Updating Firmware
- If Firmware is up to date, continue to next step.
- TXM Probes work differently over Bluetooth than other MEATER suite of products. TXM probes aren’t actually “connected” to our touchscreen grills in the traditional sense of Bluetooth. They constantly advertise/broadcast packets, and these packets contain temperature/battery information needed to use the probe. This additional temperature/battery information allows touchscreen grills to continuously scan for the advertisements and avoid actually establishing a connection the grill to miss packets and think it’s disconnected. If you find that the probes disconnect after 5-10 minutes, then it’s likely this is the cause.
- Dock your probe and then see how responsive the connection is, if the probe remains connected afterwards for a short while and then the issue comes back then this is a limitation of the Firmware and Bluetooth “connection” scheme. give our Customer Support a call and we'll be happy to help.
- Incorrect Probes.
- Do you have more than one set of MEATER probes? Verify you have not accidently swapped probes from different MEATER families.
- The battery could be depleting quickly.
- Verify the probe has connected before and you have been able to monitor its battery over time (you have been able to view it on the touchscreen display). If the probe has worked previously, and the above steps have been verified Please reach out to Customer Service.