What to do if you get a Slow Ignition notification on your D2 WiFIRE grill or in the Traeger app.
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D2 WiFIRE Grill Wiring
Applicable Grills
If you have a new Timberline or Ironwood, please see, Ignitor not Detected - Timberlines & Ironwoods, for diagnostic steps specific to your model.
This article applies to Traeger's D2 WiFIRE grills. D2 grills are Traeger grills with WiFIRE technology that have a dot matrix FSTN display.
D2 Grills include the following models:
- Century 885
- Ironwood 650
- Ironwood 885
- Pro 575
- Pro 780
- Redland
- Silverton 620
- Silverton 810
- Silverton XL
- Timberline 850
-
Timberline 1300
Symptoms
If your grill is showing a Slow Ignition notification, it means it's taking longer to reach the set temperature than normal. This occurs when the grill is igniting, and the temperature does not rise after 15 minutes.
Once the grill ignites after this notification occurs, it is common for the grill to overshoot the set temperature briefly before then leveling out for the remainder of the cook.
Causes
- Cold weather
- Running out of pellets
- Overfilled firepot
- Pellet quality
- Sawdust
- Ash accumulation/lack of maintenance
What to Do
A Slow ignition Error is a notification that is for information purposes only and usually doesn't need action. If the grill doesn't end up igniting successfully, it should push a "Failed to Ignite" error.
If you have any questions, we invite you to contact our Customer Support team, available 365 days a year.